博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
zju 1003 zoj 1003
阅读量:4120 次
发布时间:2019-05-25

本文共 3388 字,大约阅读时间需要 11 分钟。

Crashing Balloon

Time Limit: 2 Seconds     
Memory Limit: 65536 KB

On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.  The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100.  After the referee shouts "Let's go!"the two players, who each starts with a score of  "1", race to crashthe balloons by their feet and, at the same time,multiply their scores by the numbers written on the balloons they crash. After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his\her score, the product of the numberson the balloons he\she's crashed.  The unofficial winner is the player whoannounced the highest score.

Inevitably, though, disputes arise, and so the official winner is notdetermined until the disputes are resolved.  The player who claimsthe lower score is entitled to challenge his\her opponent's score.  Theplayer with the lower score is presumed to have told the truth, becauseif he\she were to lie about his\her score, he\she would surely come up with a biggerbetter lie.  The challenge is upheld if the player with the higherscore has a score that cannot be achieved with balloons not crashed by thechallenging player.  So, if the challenge is successful, the playerclaiming the lower score wins.

So, for example, if one player claims 343 points and the other claims49, then clearly the first player is lying; the only way to score 343 isby crashing balloons labeled 7 and 49, and the only way to score 49 is by crashinga balloon labeled 49.  Since each of two scores requires crashing theballoon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims81, it is possible for both to be telling the truth (e.g. one crashes balloons2, 3 and 27, while the other crashes balloon 81), so the challenge would notbe upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are tellingthe truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon islikely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculationsthat refereeing requires.  Hence the need for you, sober programmer,to provide a software solution.

Input

Pairs of unequal, positive numbers, with each pair on a single line, thatare claimed scores from a game of crashing balloon.

Output

Numbers, one to a line, that are the winning scores, assuming that theplayer with the lower score always challenges the outcome.

Sample Input

343 493599 61062 36

Sample Output

4961062

这题我想了好长时间都没有什么非常好的算法,我的想法是把所有因子提出来,然后针对那些因子作什么处理不是很清楚,最后搜到一种比较直观比较好理解的算法,是用回溯做的,如果之前因为这题烦恼挺长时间的人看了应该会有收获,其实挺简单的。

#include<stdio.h>

int flag1,flag2;
int dfs(n,m,fac){
    if(m==1) flag2=1;
    if(m==1&&n==1) {
        flag1=1,flag2=1;
        return 0;
    }
    if(fac<2) return 0;
    if(!(n%fac)) dfs(n/fac,m,fac-1);
    if(!(m%fac)) dfs(n,m/fac,fac-1);
    dfs(n,m,fac-1);
}
int main(){
    int n,m,tmp;
    while(scanf("%d%d",&n,&m)!=EOF){
        flag1=0,flag2=0;
        if(m>n){
            tmp=n;
            n=m;
            m=tmp;
        }
        dfs(n,m,100);
        if(flag1||!flag2) printf("%d\n",n);
        else if(!flag1&&flag2) printf("%d\n",m);
    }
    return 0;
}

转载地址:http://oxtpi.baihongyu.com/

你可能感兴趣的文章
Android中AsyncTask的简单用法
查看>>
带WiringPi库的交叉笔译如何处理二之软链接概念
查看>>
Java8 HashMap集合解析
查看>>
fastcgi_param 详解
查看>>
poj 1976 A Mini Locomotive (dp 二维01背包)
查看>>
MODULE_DEVICE_TABLE的理解
查看>>
db db2_monitorTool IBM Rational Performace Tester
查看>>
postgresql监控工具pgstatspack的安装及使用
查看>>
【JAVA数据结构】双向链表
查看>>
【JAVA数据结构】先进先出队列
查看>>
Objective-C 基础入门(一)
查看>>
Flutter Boost的router管理
查看>>
iOS开发支付集成之微信支付
查看>>
C++模板
查看>>
【C#】如何实现一个迭代器
查看>>
【C#】利用Conditional属性完成编译忽略
查看>>
DirectX11 光照演示示例Demo
查看>>
VUe+webpack构建单页router应用(一)
查看>>
Node.js-模块和包
查看>>
(python版)《剑指Offer》JZ01:二维数组中的查找
查看>>